Intermittent performance issues affecting some users
Incident Report for Show My Homework
Resolved
We are pleased to let you know that the issue that had been causing slow speeds for some users or trouble logging has now been resolved. Once again apologies for any inconvenience this may have caused.
Posted over 2 years ago. Jan 31, 2017 - 17:25 GMT
Investigating
We are currently investigating reports of intermittent issues affecting some of our customers. You may experience degraded performance while browsing the site, so please be aware that we are working to resolve this issue as quickly as possible. Further updates will be posted on this space as they become available.
Posted over 2 years ago. Jan 31, 2017 - 16:43 GMT