Issues experienced with Timetables
Incident Report for Show My Homework
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 08, 2017 - 16:35 BST
Investigating
We are presently experiencing problems with the Timetables feature inside Show My Homework, resulting in students being unable to access their timetable for the new academic year. Given this, we have disabled the Timetables features inside the site to allow the Satchel Engineering team to troubleshoot the issue. This issue impacts all Show My Homework users, including users of our mobile applications.

We thank you for cooperation whilst we investigate this issue and please be assured that we will do our utmost to address this as quickly as possible
Posted over 1 year ago. Sep 04, 2017 - 10:27 BST