Loading issues
Incident Report for Satchel One
Resolved
There have been no further issues since our last update, so this incident has now been fully resolved. Once again we'd like to thank you for your patience!
Posted Jan 05, 2021 - 13:05 GMT
Monitoring
The website and app should once again be responsive. We will continue to monitor things to ensure there aren't any more issues moving forward.

Thanks again for your patience!
Posted Jan 05, 2021 - 11:38 GMT
Investigating
We are aware of the Satchel One app and website being very slow or even unresponsive for some at the moment. Our engineering team are working hard to rectify the issue, and we will update you with more information as soon as we can.

Apologies for the inconvenience and thank you for your patience while we are working on this.
Posted Jan 05, 2021 - 11:04 GMT
This incident affected: Satchel One Website and iOS & Android Apps.