Urgent Maintenance work on Show My Homework Site
Incident Report for Show My Homework
Resolved
We made a number of infrastructural changes on Monday 11th to accommodate the traffic we were experiencing, however, it was apparent by late afternoon on Tuesday 12th that these changes were insufficient given the further problems experienced by users. Another incident was raised here (see http://showmyhomework.statuspage.io/incidents/hb3wzlr58dkt) in relation to the problems experienced Tuesday, and normal service was resumed late Tuesday evening.

A full post-mortem regarding these incidents has been circulated to all Show My Homework schools regarding this matter.
Posted over 1 year ago. Sep 13, 2017 - 21:55 BST
Monitoring
The Show My Homework site is now operational again. We will continue to monitor the situation over the coming hours to ensure we do not experience a similar degradation in performance, but all users should now be able to use all features of the site without issue.
Posted over 1 year ago. Sep 11, 2017 - 23:07 BST
Update
Many thanks for your patience regarding this matter. The Engineering team are making progress here, however, there will still be performance degradation on the Show My Homework site whilst we continue to make changes to the operational environment.
Posted over 1 year ago. Sep 11, 2017 - 22:27 BST
Identified
We are presently undertaking urgent work to address the performance issues identified earlier today. Unfortunately, this work is unavoidable given the problems experienced today, however, we believe it is necessary to ensure Satchel can provide an acceptable level of service to our users.

We apologise for this interruption to service and please be assured that we will do our utmost to address this as quickly as possible.
Posted over 1 year ago. Sep 11, 2017 - 18:21 BST
Investigating
We have noticed that users are experiencing delays when either logging in to the site or attempt or reference any data. Similar issues are being experienced by users of our mobile applications (both IOS and Android). We are investigating the issue at present.

We thank you for cooperation whilst we investigate this issue and please be assured that we will do our utmost to address this as quickly as possible.
Posted over 1 year ago. Sep 11, 2017 - 15:53 BST