Decreased site performance
Incident Report for Show My Homework
Resolved
Show My Homework is fully operational again.

Amazon have rectified the issues they were experiencing this morning.

Thank you for your patience.
Posted 8 months ago. Sep 26, 2018 - 11:49 BST
Update
We are continuing to work on a fix for this issue.
Posted 8 months ago. Sep 26, 2018 - 11:45 BST
Update
We are continuing to work on a fix for this issue.
Posted 8 months ago. Sep 26, 2018 - 11:45 BST
Identified
Amazon Web Services, the hosting platform that we use to distribute Show My Homework, is currently reporting increased errors within some of their European servers.

https://status.aws.amazon.com/

We are attempting to reconfigure our application to work around the parts of their system which are experiencing issues.

We will post another update once our changes go live.
Posted 8 months ago. Sep 26, 2018 - 09:39 BST
Investigating
We are investigating increased error rates and slow page loads for some of our users throughout the website. We will provide more details shortly.
Posted 8 months ago. Sep 26, 2018 - 09:15 BST
This incident affected: Show My Homework Website.