Classes not loading for some users
Incident Report for Show My Homework
Resolved
We are happy to confirm that the previous issues which prevented some users from accessing or managing classes have now been resolved!

Following our latest update from the engineering team, teachers will now be able to load "My classes", as well as search for any class at the school. Similarly, administrators will be able to load the "Manage classes" page faster than ever.

We have taken the necessary steps to prevent these issues from recurring. Thank you very much for your patience and continued support.
Posted about 1 year ago. May 22, 2018 - 23:15 BST
Update
We are continuing to work on a fix for this issue. We have released a first update that has resolved the problem for some teachers who will now be able to load their "My classes" page. Teachers will continue to experience problems when selecting the "Show other classes" option while setting homework.

Administrators who used to see an error message while loading the "Manage classes" page will likely no longer see the error screen. However, please be advised that the page will take a long time to load (upwards of 60 seconds). During that time, it may seem that the page is not loading, so please be patient while we iron things out!

We will continue working on this problem tonight and posting updates on this space as they become available.

We apologise for the delay in rectifying this problem and thank you for your patience.
Posted about 1 year ago. May 22, 2018 - 18:53 BST
Identified
We are currently working on a solution to an issue with accessing classes that some of our users have been experiencing since last week.

A subset of our Teachers and Administrators have been unable to load classes on their My classes or Manage classes pages respectively. This issue is intermittent and is affecting specific users within a school.

The problem has been isolated, a fix has been developed, and we are in the process of testing the fix thoroughly before releasing it. We understand and are deeply sorry for the impact this has caused to our users and are putting measures in place to prevent recurrences.

The background:
The issue has been identified as a side-effect of the database migration we performed last week to ensure GDPR compliance. The migration was successful and was completed without any errors. However, our new database on Amazon Aurora is handling a specific request differently, e.g. when loading a list of items, such as a class list. As a result, some teachers using the site are not seeing a list of class groups when they go to set homework or otherwise manage class groups.

Despite best intentions and regression testing, this was not caught during Quality Assurance as user-specific. The issue could not have been anticipated, although we have since contacted Amazon about the problem and have received further advice.
Posted about 1 year ago. May 22, 2018 - 14:20 BST