Blank screen on Internet Explorer
Incident Report for Show My Homework
Resolved
We have identified and resolved the issue with Internet Explorer. The white pages were caused by Microsoft’s latest security update, which you can read more about here:
https://support.microsoft.com/en-us/help/4052978/cumulative-security-update-for-internet-explorer

Thank you for your patience!
Posted 5 months ago. Aug 25, 2018 - 13:30 BST
Investigating
We are investigating some reports from users who have been unable to load our Login page on Internet Explorer.

If you have access to a different browser (Chrome, Opera, Firefox, Safari etc.) or the SMHW mobile app, please use that instead.

We apologise for any trouble this may have caused, and we will update you with more information as soon as possible.
Posted 5 months ago. Aug 23, 2018 - 15:38 BST
This incident affected: Show My Homework Website.