Still experiencing login issues?
Incident Report for Satchel One
Resolved
This incident has been resolved.
Posted Sep 13, 2022 - 18:00 BST
Update
We will continue to monitor the situation until we are certain it is fully resolved.
Posted Sep 13, 2022 - 10:34 BST
Update
We have made some further improvements to assist users who were seeing a spinner on the login button when they returned to the website after having successfully logged in before.

Visiting the login page or school public home page after having previously logged in on the same device will now redirect users to their dashboard. This will eliminate the need to log in again since they already have an active session.
Posted Sep 13, 2022 - 10:34 BST
Monitoring
This issue should now be fixed but if you are still having issues please try logging out for your Office or Google account first, and then clear cache.

You can read more details about this here:
https://status.satchelone.com/incidents/r5xyzykr4klj
Posted Sep 09, 2022 - 11:15 BST
This incident affected: Single Sign-on : Google and Single Sign-on: Office 365.