Slow page loads across the platform
Incident Report for Satchel One
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 17:08 GMT
Update
We are happy to announce that the earlier performance issues faced by some users have been resolved. We have been monitoring this closely and can confirm that no further issues have occurred in the last 3 hours; Satchel One and the Show My Homework app are both performing well.

We will of course continue to monitor the situation and are planning on performing an additional maintenance task overnight to further improve the service tomorrow. This will be scheduled outside working hours to ensure your schedule will not be interrupted.

Thank you very much for your patience today. Team Satchel will continue to support students, parents, and teachers with distance learning.
Posted Mar 23, 2020 - 15:50 GMT
Update
This is a quick update to let you know that the site performance has been steadily improving. Some users who previously faced loading difficulties will have already seen a noticeable improvement.

We are still working hard on fully restoring the service and we will continue to update you until we are back to normal.
Posted Mar 23, 2020 - 13:07 GMT
Monitoring
Our site is up and running, however, we are aware that the platform may appear slow or unresponsive for some users as millions of users are heavily relying on our product for their distance learning needs.

We are monitoring the situation very closely to ensure that we can continue to provide students, parents and teachers the support they need during this unprecedented time.
Posted Mar 23, 2020 - 10:54 GMT
This incident affected: Satchel One Website, iOS & Android Apps, Reports, Text-to-Speech Service, Email Notifications, Single Sign-on: Active Directory, Single Sign-on : Google, Single Sign-on: Office 365, Single Sign-on: RM Unify, Help Centre, and Data sync: Groupcall XoD.