Slow performance for school search, calendars, and login
Incident Report for Show My Homework
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 11, 2017 - 10:30 BST
Monitoring
We identified and corrected the issue that was causing slow performance for users. We will continue to monitor the speed of the site to ensure it continues to function as expected. Thank you again for your patience while we corrected this issue.
Posted over 1 year ago. Sep 11, 2017 - 08:47 BST
Investigating
We are investigating reports that the Show My Homework website and mobile apps are performing poorly for users at the moment. The ability to search for a school, view a school homework calendar, and log in to Show My Homework are all affected at this time. We appreciate your patience while we investigate the cause of this problem, and we will provide updates as soon as we move towards a resolution.
Posted over 1 year ago. Sep 11, 2017 - 08:38 BST